# CVE-2026-56270: Flowise - Unauthenticated OAuth Secrets Disclosure via /api/v1/loginmethod Endpoint

> Unauthenticated attackers can retrieve cleartext OAuth secrets from the loginmethod endpoint, exposing sensitive SSO credentials for major providers.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-6pcv-j4jx-m4vx

## What is CVE-2026-56270?

CVE-2026-56270 is a high-severity vulnerability in Flowiseai Flowise, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise before 3.1.0 (versions 3.0.13 and earlier) contains a missing authentication vulnerability in the /api/v1/loginmethod endpoint that allows unauthenticated users to retrieve an organization's complete SSO configuration, including OAuth client secrets in cleartext, by providing an organizationId parameter. Remote attackers can send a GET request to harvest sensitive API credentials for Google, Microsoft/Azure, GitHub, and Auth0 integrations. This affects FlowiseAI Cloud and self-hosted instances where the endpoint is exposed.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-56270?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.0 |
| `flowise` | npm | All versions | 3.1.0 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-56270?

Upgrade flowise to 3.1.0 or later.

## Is CVE-2026-56270 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56270 exists.

Public exploit code:

- Flowise <= 3.0.13 - Unauthenticated OAuth Configuration Disclosure (nuclei): http/cves/2026/CVE-2026-56270.yaml

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56270 and fix it if it is affected.

What it is: CVE-2026-56270 is a high-severity vulnerability in Flowiseai Flowise, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56270 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.0
- flowise (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56270/ (Markdown: https://insights.sbomify.com/CVE-2026-56270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56270
- OSV: https://osv.dev/vulnerability/CVE-2026-56270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56270/
Summaries are generated and may contain mistakes; the official description above is the record.
