CVE-2026-56271 Flowise - Weak Default JWT Secrets in Authentication Middleware
Attackers can forge JWTs using hardcoded default secrets to bypass authentication and impersonate administrators in Flowise.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-56271?
CVE-2026-56271 is a critical vulnerability in Flowiseai Flowise, published on 12 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Flowise before 3.1.0 (affected versions 3.0.13 and earlier) uses weak hardcoded default JWT secrets ('auth_token', 'refresh_token') and default audience and issuer values ('AUDIENCE', 'ISSUER') in the enterprise passport authentication middleware (packages/server/src/enterprise/middleware/passport/index.ts). When the corresponding environment variables (JWT_AUTH_TOKEN_SECRET, JWT_REFRESH_TOKEN_SECRET, JWT_AUDIENCE, JWT_ISSUER) are not set, the application silently falls back to these publicly known defaults, allowing an attacker to forge valid JWTs and impersonate any user, including administrators, resulting in authentication bypass.
Weakness: CWE-321
Which versions are affected by CVE-2026-56271?
2 open source packages ship an affected version, including flowise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | All versions | 3.1.0 |
flowise npm | All versions | 3.1.0 |
Products include Flowiseai Flowise.
How do I fix CVE-2026-56271?
Upgrade flowise to 3.1.0 or later.
Is CVE-2026-56271 being exploited?
There is no known exploitation of CVE-2026-56271 in the wild and no public exploit code.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-cc4f-hjpj-g9p8, GHSA-jpvq-qwhh-pw47.