# CVE-2026-56271: Flowise - Weak Default JWT Secrets in Authentication Middleware

> Attackers can forge JWTs using hardcoded default secrets to bypass authentication and impersonate administrators in Flowise.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-cc4f-hjpj-g9p8, GHSA-jpvq-qwhh-pw47

## What is CVE-2026-56271?

CVE-2026-56271 is a critical vulnerability in Flowiseai Flowise, published on 12 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise before 3.1.0 (affected versions 3.0.13 and earlier) uses weak hardcoded default JWT secrets ('auth_token', 'refresh_token') and default audience and issuer values ('AUDIENCE', 'ISSUER') in the enterprise passport authentication middleware (packages/server/src/enterprise/middleware/passport/index.ts). When the corresponding environment variables (JWT_AUTH_TOKEN_SECRET, JWT_REFRESH_TOKEN_SECRET, JWT_AUDIENCE, JWT_ISSUER) are not set, the application silently falls back to these publicly known defaults, allowing an attacker to forge valid JWTs and impersonate any user, including administrators, resulting in authentication bypass.

Weakness: CWE-321 (Use of Hard-coded Cryptographic Key)

## Which versions are affected by CVE-2026-56271?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.0 |
| `flowise` | npm | All versions | 3.1.0 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-56271?

Upgrade flowise to 3.1.0 or later.

## Is CVE-2026-56271 being exploited?

There is no known exploitation of CVE-2026-56271 in the wild and no public exploit code.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56271 and fix it if it is affected.

What it is: CVE-2026-56271 is a critical vulnerability in Flowiseai Flowise, published on 12 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56271 in the wild and no public exploit code.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.0
- flowise (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56271/ (Markdown: https://insights.sbomify.com/CVE-2026-56271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56271
- OSV: https://osv.dev/vulnerability/CVE-2026-56271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56271/
Summaries are generated and may contain mistakes; the official description above is the record.
