# CVE-2026-56272: Flowise - Insufficient Password Salt Rounds in Bcrypt Hashing

> Flowise uses weak bcrypt salt rounds, allowing attackers to crack password hashes faster and potentially compromise user accounts.

- **Severity:** Medium 5.6 (`CVSS:4.0/AV:L/AC:H/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-x2g5-fvc2-gqvp

## What is CVE-2026-56272?

CVE-2026-56272 is a medium-severity vulnerability in Flowiseai Flowise, published on 24 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Flowise before 3.0.13 uses bcrypt with default salt rounds of 5, providing only 32 iterations instead of the OWASP-recommended minimum of 10 rounds. Attackers can crack password hashes approximately 30 times faster with modern GPU hardware, potentially compromising all user accounts in a database breach scenario.

Weakness: CWE-916 (Use of Password Hash With Insufficient Computational Effort)

## Which versions are affected by CVE-2026-56272?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.0.13 |
| `flowise` | npm | All versions | 3.0.13 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-56272?

Upgrade flowise to 3.0.13 or later.

## Is CVE-2026-56272 being exploited?

There is no known exploitation of CVE-2026-56272 in the wild and no public exploit code.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56272 and fix it if it is affected.

What it is: CVE-2026-56272 is a medium-severity vulnerability in Flowiseai Flowise, published on 24 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56272 in the wild and no public exploit code.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.0.13
- flowise (npm): affected all versions; fixed in 3.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56272/ (Markdown: https://insights.sbomify.com/CVE-2026-56272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56272
- OSV: https://osv.dev/vulnerability/CVE-2026-56272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56272/
Summaries are generated and may contain mistakes; the official description above is the record.
