{"answers":{"affected":"4 open source packages ship an affected version, including flowise and flowise-components.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56273 exists.","fix":"Upgrade flowise to 3.1.0 or later.","what":"CVE-2026-56273 is a medium-severity path traversal vulnerability in Flowise, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56273 and fix it if it is affected.\n\nWhat it is: CVE-2026-56273 is a medium-severity path traversal vulnerability in Flowise, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56273 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 3.1.0\n- flowise (npm): affected all versions; fixed in 3.1.0\n- flowise-components (npm): affected all versions; fixed in 3.1.0\n- flowise-components (npm): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56273/ (Markdown: https://insights.sbomify.com/CVE-2026-56273/index.md)","id":"CVE-2026-56273","markdown":"https://insights.sbomify.com/CVE-2026-56273/index.md","name":"CVE-2026-56273","record":{"aliases":["GHSA-g8g5-48h4-5r8h","GHSA-w6v6-49gh-mc9w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Flowise AI platform","requires_auth":"low_privilege","summary":"Authenticated attackers can exploit path traversal in Flowise vector stores to write data to arbitrary locations, potentially leading to code execution or data exfiltration.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Flowise before 3.1.0 contains a path traversal vulnerability in Faiss and SimpleStore vector store implementations that accept unsanitized basePath parameters from authenticated users. Attackers with valid API tokens can write vector store data to arbitrary filesystem locations, potentially enabling code execution or data exfiltration.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Flowise - Path Traversal in Vector Store basePath Parameter","id":"CVE-2026-56273","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"Flowise - Remote Code Execution via MCP Security Bypass in validateCommandFlags and validateArgsForLocalFileAccess","id":"CVE-2026-56274"},"packages":[{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-w6v6-49gh-mc9w"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-w6v6-49gh-mc9w"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise-components","purl":null,"source":"GHSA-w6v6-49gh-mc9w"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise-components","purl":"pkg:npm/flowise-components","source":"GHSA-w6v6-49gh-mc9w"}],"prev":{"headline":"Flowise - Insufficient Password Salt Rounds in Bcrypt Hashing","id":"CVE-2026-56272"},"products":["Flowise"],"published":"2026-07-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["Flowise"]},"summary":"Authenticated attackers can exploit path traversal in Flowise vector stores to write data to arbitrary locations, potentially leading to code execution or data exfiltration.","url":"https://insights.sbomify.com/CVE-2026-56273/"}