# CVE-2026-56273: Flowise - Path Traversal in Vector Store basePath Parameter

> Authenticated attackers can exploit path traversal in Flowise vector stores to write data to arbitrary locations, potentially leading to code execution or data exfiltration.

- **Severity:** Medium 4.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-g8g5-48h4-5r8h, GHSA-w6v6-49gh-mc9w

## What is CVE-2026-56273?

CVE-2026-56273 is a medium-severity path traversal vulnerability in Flowise, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise before 3.1.0 contains a path traversal vulnerability in Faiss and SimpleStore vector store implementations that accept unsanitized basePath parameters from authenticated users. Attackers with valid API tokens can write vector store data to arbitrary filesystem locations, potentially enabling code execution or data exfiltration.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-56273?

4 open source packages ship an affected version, including flowise and flowise-components.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.0 |
| `flowise` | npm | All versions | 3.1.0 |
| `flowise-components` | npm | All versions | 3.1.0 |
| `flowise-components` | npm | All versions | 3.1.0 |

## How do I fix CVE-2026-56273?

Upgrade flowise to 3.1.0 or later.

## Is CVE-2026-56273 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56273 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56273 and fix it if it is affected.

What it is: CVE-2026-56273 is a medium-severity path traversal vulnerability in Flowise, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56273 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.0
- flowise (npm): affected all versions; fixed in 3.1.0
- flowise-components (npm): affected all versions; fixed in 3.1.0
- flowise-components (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56273/ (Markdown: https://insights.sbomify.com/CVE-2026-56273/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56273
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56273
- OSV: https://osv.dev/vulnerability/CVE-2026-56273

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56273/
Summaries are generated and may contain mistakes; the official description above is the record.
