# CVE-2026-56274: Flowise - Remote Code Execution via MCP Security Bypass in validateCommandFlags and validateArgsForLocalFileAccess

> Attackers can execute arbitrary commands on the host by configuring a malicious MCP server that bypasses validation checks in Flowise.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-8rhx-2hcv-q49g, GHSA-m99r-2hxc-cp3q

## What is CVE-2026-56274?

CVE-2026-56274 is a high-severity command injection vulnerability in Flowiseai Flowise, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise before 3.1.2 contains multiple OS command injection vulnerabilities in the Custom MCP Server feature due to incomplete command-flag validation and a regex bypass in local file access restrictions. An attacker with a Flowise account of any role, or API access with view/update permissions for chatflows, can configure a malicious MCP server to bypass the validateCommandFlags blocklist (for example, 'docker build' is not blocked, and 'npx --yes' is not blocked while only '-y' is) and the validateArgsForLocalFileAccess checks, resulting in execution of arbitrary commands on the Flowise host.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-56274?

4 open source packages ship an affected version, including flowise and flowise-components. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.2 |
| `flowise` | npm | All versions | 3.1.2 |
| `flowise-components` | npm | All versions | 3.1.2 |
| `flowise-components` | npm | All versions | 3.1.2 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-56274?

Upgrade flowise to 3.1.2 or later.

## Is CVE-2026-56274 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56274 exists.

Public exploit code:

- Flowise MCP Server Remote Code Execution (metasploit)

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56274 and fix it if it is affected.

What it is: CVE-2026-56274 is a high-severity command injection vulnerability in Flowiseai Flowise, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56274 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.2
- flowise (npm): affected all versions; fixed in 3.1.2
- flowise-components (npm): affected all versions; fixed in 3.1.2
- flowise-components (npm): affected all versions; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56274/ (Markdown: https://insights.sbomify.com/CVE-2026-56274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56274
- OSV: https://osv.dev/vulnerability/CVE-2026-56274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56274/
Summaries are generated and may contain mistakes; the official description above is the record.
