# CVE-2026-56275: Flowise - Server-Side Request Forgery via Execute Flow Base URL

> Attackers can exploit Flowise to perform server-side request forgery, accessing internal networks and cloud metadata via the Execute Flow node.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-9hrv-gvrv-6gf2

## What is CVE-2026-56275?

CVE-2026-56275 is a medium-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise before 3.1.0 contains a server-side request forgery vulnerability in the Execute Flow node that allows attackers to bypass security validation by providing intranet addresses through the base URL field. Attackers can initiate HTTP requests to internal network addresses, access cloud metadata, and enumerate internal services by exploiting the missing secureFetch verification in httpSecurity.ts.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-56275?

4 open source packages ship an affected version, including flowise and flowise-components. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.0 |
| `flowise` | npm | All versions | 3.1.0 |
| `flowise-components` | npm | All versions | 3.1.0 |
| `flowise-components` | npm | All versions | 3.1.0 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-56275?

Upgrade flowise to 3.1.0 or later.

## Is CVE-2026-56275 being exploited?

There is no known exploitation of CVE-2026-56275 in the wild and no public exploit code.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56275 and fix it if it is affected.

What it is: CVE-2026-56275 is a medium-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56275 in the wild and no public exploit code.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.0
- flowise (npm): affected all versions; fixed in 3.1.0
- flowise-components (npm): affected all versions; fixed in 3.1.0
- flowise-components (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56275/ (Markdown: https://insights.sbomify.com/CVE-2026-56275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56275
- OSV: https://osv.dev/vulnerability/CVE-2026-56275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56275/
Summaries are generated and may contain mistakes; the official description above is the record.
