# CVE-2026-56276: Flowise - Mass Assignment in PUT /api/v1/user Allows Password Hash Override

> Authenticated users can override password hashes via mass assignment, enabling persistent account takeover and bypassing session invalidation.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-59fh-9f3p-7m39, GHSA-qr8q-6c25-rppr

## What is CVE-2026-56276?

CVE-2026-56276 is a medium-severity missing authorization vulnerability in Flowise, published on 20 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise before 3.1.2 contains a mass assignment vulnerability in the PUT /api/v1/user endpoint that allows authenticated users to directly modify the credential field without validation. Attackers can bypass password change verification and session invalidation by supplying a crafted password hash, establishing persistent account access after temporary session compromise.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2026-56276?

2 open source packages ship an affected version, including flowise.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.2 |
| `flowise` | npm | All versions | 3.1.2 |

## How do I fix CVE-2026-56276?

Upgrade flowise to 3.1.2 or later.

## Is CVE-2026-56276 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56276 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56276 and fix it if it is affected.

What it is: CVE-2026-56276 is a medium-severity missing authorization vulnerability in Flowise, published on 20 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56276 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.2
- flowise (npm): affected all versions; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56276/ (Markdown: https://insights.sbomify.com/CVE-2026-56276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56276
- OSV: https://osv.dev/vulnerability/CVE-2026-56276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56276/
Summaries are generated and may contain mistakes; the official description above is the record.
