{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-56277 in the wild and no public exploit code.","fix":"Upgrade flowise to 3.1.2 or later.","what":"CVE-2026-56277 is a medium-severity vulnerability in Flowiseai Flowise, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56277 and fix it if it is affected.\n\nWhat it is: CVE-2026-56277 is a medium-severity vulnerability in Flowiseai Flowise, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-56277 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 3.1.2\n- flowise (npm): affected all versions; fixed in 3.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56277/ (Markdown: https://insights.sbomify.com/CVE-2026-56277/index.md)","id":"CVE-2026-56277","markdown":"https://insights.sbomify.com/CVE-2026-56277/index.md","name":"CVE-2026-56277","record":{"aliases":["GHSA-8m62-6r3h-3x25","GHSA-m837-xvxr-vqwg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Flowise AI platform","requires_auth":"none","summary":"Attackers can bypass CORS restrictions to trigger TTS generation using stored credentials via cross-origin requests.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-346","name":"Origin Validation Error"}],"description":"Flowise before 3.1.2 sets Access-Control-Allow-Origin to a hardcoded wildcard (*) on its text-to-speech (TTS) generation endpoint (packages/server/src/controllers/text-to-speech/index.ts), independent of the server's configured CORS policy. This bypasses the server's otherwise restrictive default CORS configuration (getCorsOptions()) and allows any webpage to make cross-origin requests that trigger TTS generation using stored credentials, enabling drive-by cross-origin credential abuse.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Flowise - Hardcoded CORS Wildcard in TTS Endpoint","id":"CVE-2026-56277","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Flowise - Session Hijacking via Weak Default Express Session Secret","id":"CVE-2026-56278"},"packages":[{"ecosystem":"npm","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-m837-xvxr-vqwg"},{"ecosystem":"npm","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-m837-xvxr-vqwg"}],"prev":{"headline":"Flowise - Mass Assignment in PUT /api/v1/user Allows Password Hash Override","id":"CVE-2026-56276"},"products":["Flowise"],"published":"2026-06-30","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-01","vendors":["Flowise"]},"summary":"Attackers can bypass CORS restrictions to trigger TTS generation using stored credentials via cross-origin requests.","url":"https://insights.sbomify.com/CVE-2026-56277/"}