CVE-2026-56278 Flowise - Session Hijacking via Weak Default Express Session Secret
Attackers can forge session cookies using a hardcoded default secret to impersonate users and bypass authentication in Flowise.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-56278?
CVE-2026-56278 is a critical vulnerability in Flowiseai Flowise, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Flowise before 3.1.0 (affected versions 3.0.13 and earlier) uses a weak hardcoded default secret ('flowise') for the express-session middleware when the EXPRESS_SESSION_SECRET environment variable is not set (packages/server/src/enterprise/middleware/passport/index.ts). Because this default secret is publicly visible in the source code, an attacker can forge valid signed session cookies to impersonate any user and bypass authentication.
Weakness: CWE-798
Which versions are affected by CVE-2026-56278?
2 open source packages ship an affected version, including flowise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | All versions | 3.1.0 |
flowise npm | All versions | 3.1.0 |
Products include Flowiseai Flowise.
How do I fix CVE-2026-56278?
Upgrade flowise to 3.1.0 or later.
Is CVE-2026-56278 being exploited?
There is no known exploitation of CVE-2026-56278 in the wild and no public exploit code.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-2qqc-p94c-hxwh, GHSA-c973-v3cg-wcw4.