# CVE-2026-56315: picklescan - Remote Code Execution via Unblocked Standard Library Modules

> Attackers can achieve remote code execution by crafting malicious pickle files that bypass picklescan's validation using unblocked standard library modules.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-g38g-8gr9-h9xp, PYSEC-2026-4134

## What is CVE-2026-56315?

CVE-2026-56315 is a critical code injection vulnerability in picklescan, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

picklescan before 1.0.4 fails to block at least seven Python standard library modules (including uuid, _osx_support, _aix_support, _pyrepl.pager, and imaplib) exposing eight functions that provide direct arbitrary command execution. Attackers can craft malicious pickle files importing these unblocked modules to achieve remote code execution while bypassing picklescan's safety validation entirely.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-56315?

3 open source packages ship an affected version, including picklescan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `picklescan` | PyPI | All versions | 1.0.4 |
| `picklescan` | PyPI | All versions | 1.0.4 |
| `picklescan` | PyPI | All versions | 1.0.4 |

## How do I fix CVE-2026-56315?

Upgrade picklescan to 1.0.4 or later.

## Is CVE-2026-56315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56315 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56315 and fix it if it is affected.

What it is: CVE-2026-56315 is a critical code injection vulnerability in picklescan, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56315 exists.

Affected packages and fixed versions:
- picklescan (PyPI): affected all versions; fixed in 1.0.4
- picklescan (PyPI): affected all versions; fixed in 1.0.4
- picklescan (PyPI): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56315/ (Markdown: https://insights.sbomify.com/CVE-2026-56315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56315
- OSV: https://osv.dev/vulnerability/CVE-2026-56315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56315/
Summaries are generated and may contain mistakes; the official description above is the record.
