# CVE-2026-56349: n8n - Guardrail Node Bypass via Crafted Input

> Attackers can bypass n8n Guardrail node protections by crafting malicious inputs, compromising workflow integrity and security controls.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-9v3h-fx77-8r29, GHSA-fvfv-ppw4-7h2w

## What is CVE-2026-56349?

CVE-2026-56349 is a medium-severity vulnerability in n8n, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

n8n before version 2.10.0 contains an input validation vulnerability in the Guardrail node that allows attackers to bypass default guardrail instructions. End users can craft malicious inputs to circumvent guardrail protections and compromise workflow integrity.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-56349?

2 open source packages ship an affected version, including n8n.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 2.10.0 |
| `n8n` | npm | All versions | 2.10.0 |

## How do I fix CVE-2026-56349?

Upgrade n8n to 2.10.0 or later.

## Is CVE-2026-56349 being exploited?

There is no known exploitation of CVE-2026-56349 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56349 and fix it if it is affected.

What it is: CVE-2026-56349 is a medium-severity vulnerability in n8n, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56349 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 2.10.0
- n8n (npm): affected all versions; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56349/ (Markdown: https://insights.sbomify.com/CVE-2026-56349/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56349
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56349
- OSV: https://osv.dev/vulnerability/CVE-2026-56349

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56349/
Summaries are generated and may contain mistakes; the official description above is the record.
