CVE-2026-56353 n8n - Authentication Bypass in Chat Trigger Node
Attackers can bypass authentication on the Chat Trigger node in n8n when using User Auth, gaining unauthorized access to the webhook endpoint.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-56353?
CVE-2026-56353 is a medium-severity authentication bypass vulnerability in N8n N8n, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
n8n contains an authentication bypass in the Chat Trigger node when configured with n8n User Auth (a non-default configuration). In affected releases — before 1.123.22, the 2.0.0 through 2.9.2 line, and 2.10.0 — the authentication check on the Chat Trigger webhook endpoint can be circumvented, allowing access without valid credentials. Fixed in 1.123.22, 2.9.3, and 2.10.1.
Weakness: CWE-287
Which versions are affected by CVE-2026-56353?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.22 |
n8n npm | All versions | 1.123.22 |
n8n npm | From 2.0.0 | 2.9.3 |
n8n npm | From 2.0.0 | 2.9.3 |
n8n npm | From 2.10.0 | 2.10.1 |
n8n npm | From 2.10.0 | 2.10.1 |
Products include N8n N8n.
How do I fix CVE-2026-56353?
Upgrade n8n to a fixed version for your release line: 1.123.22, 2.9.3 or 2.10.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-56353 being exploited?
There is no known exploitation of CVE-2026-56353 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-455f-pg36-wx7g, GHSA-jh8h-6c9q-7gmw.