CVE-2026-56356 n8n - Stored Cross-Site Scripting in Chat Trigger Node Custom CSS Field
Authenticated users can inject JavaScript via the Chat Trigger node's Custom CSS field, leading to stored XSS against visitors of the public chat page.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-56356?
CVE-2026-56356 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 30 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
n8n contains a stored cross-site scripting vulnerability in the Chat Trigger node's Custom CSS field due to a misconfiguration of the sanitize-html library. Affected releases are those before 1.123.27, the 2.0.0 through 2.13.2 line, and 2.14.0 (fixed in 1.123.27, 2.13.3, and 2.14.1). An authenticated user with permission to create or modify workflows can inject JavaScript that bypasses sanitization, resulting in stored XSS against any user who visits the public chat page.
Weakness: CWE-79
Which versions are affected by CVE-2026-56356?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.27 |
n8n npm | All versions | 1.123.27 |
n8n npm | From 2.0.0-rc.0 | 2.13.3 |
n8n npm | From 2.0.0-rc.0 | 2.13.3 |
n8n npm | From 2.14.0 | 2.14.1 |
n8n npm | From 2.14.0 | 2.14.1 |
Products include N8n N8n.
How do I fix CVE-2026-56356?
Upgrade n8n to a fixed version for your release line: 1.123.27, 2.13.3 or 2.14.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-56356 being exploited?
There is no known exploitation of CVE-2026-56356 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-3c7f-5hgj-h279, GHSA-99wx-hwrx-8g4w.