# CVE-2026-56356: n8n - Stored Cross-Site Scripting in Chat Trigger Node Custom CSS Field

> Authenticated users can inject JavaScript via the Chat Trigger node's Custom CSS field, leading to stored XSS against visitors of the public chat page.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 30 Jun 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-3c7f-5hgj-h279, GHSA-99wx-hwrx-8g4w

## What is CVE-2026-56356?

CVE-2026-56356 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 30 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

n8n contains a stored cross-site scripting vulnerability in the Chat Trigger node's Custom CSS field due to a misconfiguration of the sanitize-html library. Affected releases are those before 1.123.27, the 2.0.0 through 2.13.2 line, and 2.14.0 (fixed in 1.123.27, 2.13.3, and 2.14.1). An authenticated user with permission to create or modify workflows can inject JavaScript that bypasses sanitization, resulting in stored XSS against any user who visits the public chat page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-56356?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.27 |
| `n8n` | npm | All versions | 1.123.27 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.13.3 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.13.3 |
| `n8n` | npm | From 2.14.0 | 2.14.1 |
| `n8n` | npm | From 2.14.0 | 2.14.1 |

Products: N8n N8n.

## How do I fix CVE-2026-56356?

Upgrade n8n to a fixed version for your release line: 1.123.27, 2.13.3 or 2.14.1.

## Is CVE-2026-56356 being exploited?

There is no known exploitation of CVE-2026-56356 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56356 and fix it if it is affected.

What it is: CVE-2026-56356 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 30 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-56356 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.27
- n8n (npm): affected all versions; fixed in 1.123.27
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.13.3
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.13.3
- n8n (npm): affected from 2.14.0; fixed in 2.14.1
- n8n (npm): affected from 2.14.0; fixed in 2.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56356/ (Markdown: https://insights.sbomify.com/CVE-2026-56356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56356
- OSV: https://osv.dev/vulnerability/CVE-2026-56356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56356/
Summaries are generated and may contain mistakes; the official description above is the record.
