CVE-2026-56357 n8n - Webhook Forgery via Missing HMAC-SHA256 Signature Verification in GitHub Webhook Trigger
Attackers can spoof GitHub webhook events to trigger workflows with arbitrary data due to missing signature verification in n8n.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56357?
CVE-2026-56357 is a medium-severity missing authorization vulnerability in N8n N8n, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
n8n before 1.123.15 and 2.5.0 contains a webhook forgery vulnerability in the GitHub Webhook Trigger node that fails to implement HMAC-SHA256 signature verification. Attackers who know the webhook URL can send unsigned POST requests to trigger workflows with arbitrary data, spoofing GitHub webhook events.
Weakness: CWE-290
Which versions are affected by CVE-2026-56357?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.15 |
n8n npm | All versions | 1.123.15 |
n8n npm | From 2.0.0 | 2.5.0 |
n8n npm | From 2.0.0 | 2.5.0 |
Products include N8n N8n.
How do I fix CVE-2026-56357?
Upgrade n8n to a fixed version for your release line: 1.123.15 or 2.5.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-56357 being exploited?
There is no known exploitation of CVE-2026-56357 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-mqpr-49jj-32rc.