CVE-2026-56358 n8n - Stored Cross-Site Scripting in Form Trigger Node
Authenticated users can inject persistent XSS payloads via the Form Trigger node, enabling form hijacking and phishing attacks against visitors.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-56358?
CVE-2026-56358 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 24 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
n8n before 1.123.25 (1.x) and before 2.11.2 (2.x), with the fix also included in 2.12.0, contains a stored cross-site scripting vulnerability in the Form Trigger node's CSS sanitization that allows authenticated users to inject malicious scripts. Attackers with workflow creation permissions can inject XSS payloads that execute persistently for all form visitors, enabling form hijacking and phishing attacks.
Weakness: CWE-79
Which versions are affected by CVE-2026-56358?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.25 |
n8n npm | All versions | 1.123.25 |
n8n npm | From 2.0.0-rc.0 | 2.11.2 |
n8n npm | From 2.0.0-rc.0 | 2.11.2 |
Products include N8n N8n.
How do I fix CVE-2026-56358?
Upgrade n8n to a fixed version for your release line: 1.123.25 or 2.11.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-56358 being exploited?
There is no known exploitation of CVE-2026-56358 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-q4fm-pjq6-m63g.