CVE-2026-56359 n8n - Cross-Site Scripting in Credential Management OAuth2 Authorization URL
Authenticated users can inject malicious scripts into OAuth2 URLs, allowing attackers to execute arbitrary code in victims' browsers via social engineering.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-56359?
CVE-2026-56359 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
n8n before 2.8.0 contains a cross-site scripting vulnerability in the credential management flow where authenticated users can inject malicious JavaScript URLs into OAuth2 credential Authorization URL fields. Attackers can craft malicious credentials and trick victims into clicking the OAuth authorization button, executing arbitrary scripts in their browser session with the victim's privileges.
Weakness: CWE-79
Which versions are affected by CVE-2026-56359?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 2.6.4 |
n8n npm | All versions | 2.6.4 |
n8n npm | From 2.7.0 | 2.8.0 |
n8n npm | From 2.7.0 | 2.8.0 |
Products include N8n N8n.
How do I fix CVE-2026-56359?
Upgrade n8n to a fixed version for your release line: 2.6.4 or 2.8.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-56359 being exploited?
There is no known exploitation of CVE-2026-56359 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-364x-8g5j-x2pr, GHSA-c4mv-j7jv-9c8f.