# CVE-2026-56361: ImageMagick - Heap Buffer Overflow via Off-by-One in Morphology Processing

> Attackers can trigger heap buffer overflows in ImageMagick via malformed morphology parameters, potentially causing crashes or code execution.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-56361, ECHO-9d87-2ca9-c2b3, GHSA-4h5w-9gq6-38f8, GHSA-q8h3-jv9v-57qx, JLSEC-2026-1042, MINI-45j6-38w7-2p4m, UBUNTU-CVE-2026-56361

## What is CVE-2026-56361?

CVE-2026-56361 is a medium-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 30 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

ImageMagick before 7.1.2-19 contains an off-by-one error in morphology validation allowing out-of-bounds heap buffer reads. Attackers can trigger heap buffer overflow by providing incorrect morphology parameters causing single pixel memory access violations.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-56361?

36 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-OpenMP-arm64. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.12.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.12.0 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2026-56361?

Upgrade Magick.NET-Q16-AnyCPU to 14.12.0 or later.

## Is CVE-2026-56361 being exploited?

There is no known exploitation of CVE-2026-56361 in the wild and no public exploit code.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56361 and fix it if it is affected.

What it is: CVE-2026-56361 is a medium-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 30 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-56361 in the wild and no public exploit code.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.12.0
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56361/ (Markdown: https://insights.sbomify.com/CVE-2026-56361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56361
- OSV: https://osv.dev/vulnerability/CVE-2026-56361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56361/
Summaries are generated and may contain mistakes; the official description above is the record.
