# CVE-2026-56366: ImageMagick - Memory Leak in META Reader APP1JPEG Error Path

> Attackers can cause denial of service via resource exhaustion by submitting crafted APP1JPEG files to ImageMagick.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-56366, ECHO-822f-c526-ce25, GHSA-377p-xr9w-8773, GHSA-9r56-3gjq-hqf7, JLSEC-2026-1047, MINI-jp3m-v67h-f93p, UBUNTU-CVE-2026-56366

## What is CVE-2026-56366?

CVE-2026-56366 is a medium-severity denial of service vulnerability in Imagemagick Imagemagick, published on 10 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

ImageMagick before 7.1.2-18 contains a memory leak vulnerability in the META reader when processing APP1JPEG input paths. Attackers can trigger this memory leak by providing specially crafted APP1JPEG image files, causing denial of service through resource exhaustion.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2026-56366?

36 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-OpenMP-arm64. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-OpenMP-x86` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-OpenMP-x86` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.11.1 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.11.1 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2026-56366?

Upgrade Magick.NET-Q16-AnyCPU to 14.11.1 or later.

## Is CVE-2026-56366 being exploited?

There is no known exploitation of CVE-2026-56366 in the wild and no public exploit code.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56366 and fix it if it is affected.

What it is: CVE-2026-56366 is a medium-severity denial of service vulnerability in Imagemagick Imagemagick, published on 10 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-56366 in the wild and no public exploit code.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-x86 (NuGet): affected all versions; fixed in 14.11.1
- Magick.NET-Q16-HDRI-x86 (NuGet): affected all versions; fixed in 14.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56366/ (Markdown: https://insights.sbomify.com/CVE-2026-56366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56366
- OSV: https://osv.dev/vulnerability/CVE-2026-56366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56366/
Summaries are generated and may contain mistakes; the official description above is the record.
