# CVE-2026-56373: ImageMagick - Use-After-Free Write in PDB Decoder

> Attackers can cause crashes or write a zero byte to freed memory by processing malicious PDB files in ImageMagick.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-56373, ECHO-a17a-4028-5497, GHSA-3j4x-rwrx-xxj9, GHSA-j6f7-9c5w-9r2q, JLSEC-2026-1054, MINI-hch6-9fj2-7mvj, UBUNTU-CVE-2026-56373

## What is CVE-2026-56373?

CVE-2026-56373 is a medium-severity use after free vulnerability in Imagemagick Imagemagick, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ImageMagick before 7.1.2-15 contains a use-after-free vulnerability in the PDB decoder that uses a stale pointer when memory allocation fails. Attackers can trigger this vulnerability by processing malicious PDB files to cause crashes or write a single zero byte to freed memory.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-56373?

38 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-OpenMP-arm64. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.10.3 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2026-56373?

Upgrade Magick.NET-Q16-AnyCPU to 14.10.3 or later.

## Is CVE-2026-56373 being exploited?

There is no known exploitation of CVE-2026-56373 in the wild and no public exploit code.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56373 and fix it if it is affected.

What it is: CVE-2026-56373 is a medium-severity use after free vulnerability in Imagemagick Imagemagick, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56373 in the wild and no public exploit code.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56373/ (Markdown: https://insights.sbomify.com/CVE-2026-56373/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56373
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56373
- OSV: https://osv.dev/vulnerability/CVE-2026-56373

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56373/
Summaries are generated and may contain mistakes; the official description above is the record.
