# CVE-2026-56381: Craft CMS - Stored XSS via User Group Name in User Permissions Page

> Admins can inject JavaScript via user group names in Craft CMS, leading to stored XSS and potential account takeover when viewed by others.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-g3hp-vvqf-8vw6

## What is CVE-2026-56381?

CVE-2026-56381 is a medium-severity cross-site scripting vulnerability in craftcms cms, published on 21 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Craft CMS from version 5.0.0-RC1 contains a stored cross-site scripting vulnerability in the User Permissions page where user group names are rendered without proper HTML escaping. Attackers with admin access can inject arbitrary JavaScript via the user group name field that executes when other users view or edit permissions.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-56381?

2 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.22 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.22 |

## How do I fix CVE-2026-56381?

Upgrade craftcms/cms to 5.8.22 or later.

## Is CVE-2026-56381 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56381 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56381 and fix it if it is affected.

What it is: CVE-2026-56381 is a medium-severity cross-site scripting vulnerability in craftcms cms, published on 21 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56381 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.22
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56381/ (Markdown: https://insights.sbomify.com/CVE-2026-56381/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56381
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56381
- OSV: https://osv.dev/vulnerability/CVE-2026-56381

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56381/
Summaries are generated and may contain mistakes; the official description above is the record.
