{"answers":{"affected":"2 open source packages ship an affected version, including craftcms/cms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56382 exists.","fix":"Upgrade craftcms/cms to 5.9.14 or later.","what":"CVE-2026-56382 is a high-severity code injection vulnerability in craftcms cms, published on 21 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56382 and fix it if it is affected.\n\nWhat it is: CVE-2026-56382 is a high-severity code injection vulnerability in craftcms cms, published on 21 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56382 exists.\n\nAffected packages and fixed versions:\n- craftcms/cms (Packagist): affected from 5.5.0; fixed in 5.9.14\n- craftcms/cms (Packagist): affected from 5.5.0; fixed in 5.9.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56382/ (Markdown: https://insights.sbomify.com/CVE-2026-56382/index.md)","id":"CVE-2026-56382","markdown":"https://insights.sbomify.com/CVE-2026-56382/index.md","name":"CVE-2026-56382","record":{"aliases":["GHSA-86vw-x4ww-x467"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Craft CMS","requires_auth":"high_privilege","summary":"Authenticated admin users can execute arbitrary PHP code and read sensitive data via unsanitized field layout configuration in Craft CMS.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Craft CMS (composer package craftcms/cms) versions \u003e= 5.5.0 and \u003c= 5.9.13 contain a remote code execution vulnerability in the FieldsController::actionRenderCardPreview() method, which passes the fieldLayoutConfig POST parameter directly to Fields::createLayout() without calling Component::cleanseConfig(). An authenticated admin user can inject Yii2 event handlers (e.g., 'on init' keys) via the fieldLayoutConfig parameter to execute arbitrary PHP code and disclose sensitive information (such as environment variables containing database credentials and CRAFT_SECURITY_KEY). The issue is fixed in version 5.9.14.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Craft CMS - Remote Code Execution via Missing Config Sanitization in FieldsController","id":"CVE-2026-56382","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Craft CMS - Stored XSS in Table Field via Row Heading Column Type","id":"CVE-2026-56383"},"packages":[{"ecosystem":"Packagist","fixed":["5.9.14"],"introduced":["5.5.0"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-86vw-x4ww-x467"},{"ecosystem":"Packagist","fixed":["5.9.14"],"introduced":["5.5.0"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-86vw-x4ww-x467"}],"prev":{"headline":"Craft CMS - Stored XSS via User Group Name in User Permissions Page","id":"CVE-2026-56381"},"products":["cms"],"published":"2026-06-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-22","vendors":["craftcms"]},"summary":"Authenticated admin users can execute arbitrary PHP code and read sensitive data via unsanitized field layout configuration in Craft CMS.","url":"https://insights.sbomify.com/CVE-2026-56382/"}