# CVE-2026-56382: Craft CMS - Remote Code Execution via Missing Config Sanitization in FieldsController

> Authenticated admin users can execute arbitrary PHP code and read sensitive data via unsanitized field layout configuration in Craft CMS.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-86vw-x4ww-x467

## What is CVE-2026-56382?

CVE-2026-56382 is a high-severity code injection vulnerability in craftcms cms, published on 21 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Craft CMS (composer package craftcms/cms) versions >= 5.5.0 and <= 5.9.13 contain a remote code execution vulnerability in the FieldsController::actionRenderCardPreview() method, which passes the fieldLayoutConfig POST parameter directly to Fields::createLayout() without calling Component::cleanseConfig(). An authenticated admin user can inject Yii2 event handlers (e.g., 'on init' keys) via the fieldLayoutConfig parameter to execute arbitrary PHP code and disclose sensitive information (such as environment variables containing database credentials and CRAFT_SECURITY_KEY). The issue is fixed in version 5.9.14.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-56382?

2 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 5.5.0 | 5.9.14 |
| `craftcms/cms` | Packagist | From 5.5.0 | 5.9.14 |

## How do I fix CVE-2026-56382?

Upgrade craftcms/cms to 5.9.14 or later.

## Is CVE-2026-56382 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56382 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56382 and fix it if it is affected.

What it is: CVE-2026-56382 is a high-severity code injection vulnerability in craftcms cms, published on 21 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56382 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 5.5.0; fixed in 5.9.14
- craftcms/cms (Packagist): affected from 5.5.0; fixed in 5.9.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56382/ (Markdown: https://insights.sbomify.com/CVE-2026-56382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56382
- OSV: https://osv.dev/vulnerability/CVE-2026-56382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56382/
Summaries are generated and may contain mistakes; the official description above is the record.
