# CVE-2026-56385: Craft CMS - Authorization Bypass in assets/preview-file Endpoint

> Authenticated low-privileged users can bypass authorization checks to view private asset previews in Craft CMS.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-44px-qjjc-xrhq

## What is CVE-2026-56385?

CVE-2026-56385 is a medium-severity missing authorization vulnerability in craftcms cms, published on 21 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft CMS versions >= 5.0.0-RC1, <= 5.9.13 and >= 4.0.0-RC1, <= 4.17.7 contain an authorization bypass in the assets/preview-file endpoint. The action does not enforce per-asset view authorization before returning preview content, allowing an authenticated low-privileged user to supply a controlled assetId for an asset they are not permitted to view and still receive preview response data (previewHtml), including a private preview image route containing the target private assetId. Fixed in 5.9.14 and 4.17.8.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-56385?

4 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.8 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.8 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.14 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.14 |

## How do I fix CVE-2026-56385?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.8 or 5.9.14.

## Is CVE-2026-56385 being exploited?

There is no known exploitation of CVE-2026-56385 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56385 and fix it if it is affected.

What it is: CVE-2026-56385 is a medium-severity missing authorization vulnerability in craftcms cms, published on 21 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56385 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.8
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.8
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.14
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56385/ (Markdown: https://insights.sbomify.com/CVE-2026-56385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56385
- OSV: https://osv.dev/vulnerability/CVE-2026-56385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56385/
Summaries are generated and may contain mistakes; the official description above is the record.
