CVE-2026-56393 Craft CMS - Multiple Stored Cross-Site Scripting in Settings Names and Field Options
Authenticated administrators can inject malicious scripts into CMS settings, leading to arbitrary JavaScript execution in other users' sessions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-56393?
CVE-2026-56393 is a medium-severity cross-site scripting vulnerability in craftcms cms, published on 21 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Craft CMS 4.x (>= 4.0.0-RC1, < 4.17.0-beta.1) and 5.x (>= 5.0.0-RC1, < 5.9.0-beta.1) contain multiple stored cross-site scripting vulnerabilities where settings names and field option labels are rendered without sanitization (e.g., via the checkbox.twig template, which used {{ label|raw }}). An authenticated administrator (with allowAdminChanges enabled) can inject malicious payloads into section names, volume names, user group names, global set names, generated field names, checkbox/radio option labels, and custom source labels, causing arbitrary JavaScript to execute in other users' control-panel sessions. Fixed in 4.17.0-beta.1 and 5.9.0-beta.1.
Weakness: CWE-79
Which versions are affected by CVE-2026-56393?
4 open source packages ship an affected version, including craftcms/cms.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |
How do I fix CVE-2026-56393?
Upgrade craftcms/cms to a fixed version for your release line: 4.17.0-beta.1 or 5.9.0-beta.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-56393 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56393 exists.
Sources
Also known as GHSA-4mgv-366x-qxvx.