# CVE-2026-56400: open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation

> Attackers can execute arbitrary code on open-webui instances by exploiting CORS misconfigurations and session validation flaws when an admin visits a malicious site.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-6xcp-7mpr-m7wm, GHSA-m5hr-9f92-qvh9

## What is CVE-2026-56400?

CVE-2026-56400 is a critical vulnerability in Openwebui Open Webui, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

open-webui before 0.3.14 contains a cross-origin resource sharing misconfiguration allowing arbitrary origins with allow_origins=* and authenticated requests to the /api/v1/functions endpoint. Attackers can execute arbitrary code on the openwebui instance by crafting malicious cross-site requests from attacker-controlled websites when an admin user visits them.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-56400?

2 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.3.33 |
| `open-webui` | PyPI | All versions | 0.3.33 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-56400?

Upgrade open-webui to 0.3.33 or later.

## Is CVE-2026-56400 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56400 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)
- [CVE-2026-70492](https://insights.sbomify.com/CVE-2026-70492/): Open WebUI: Stored XSS via unescaped KaTeX render-error fallback in rendered messages (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56400 and fix it if it is affected.

What it is: CVE-2026-56400 is a critical vulnerability in Openwebui Open Webui, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56400 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.3.33
- open-webui (PyPI): affected all versions; fixed in 0.3.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56400/ (Markdown: https://insights.sbomify.com/CVE-2026-56400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56400
- OSV: https://osv.dev/vulnerability/CVE-2026-56400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56400/
Summaries are generated and may contain mistakes; the official description above is the record.
