{"answers":{"affected":"2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 4 products.","exploited":"There is no known exploitation of CVE-2026-56434 in the wild and no public exploit code.","fix":"Upgrade nginx to a fixed version for your release line: 1.30.4 or 1.31.3.","what":"CVE-2026-56434 is a high-severity use after free vulnerability in F5 NGINX Open Source, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56434 and fix it if it is affected.\n\nWhat it is: CVE-2026-56434 is a high-severity use after free vulnerability in F5 NGINX Open Source, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-56434 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx (Bitnami): affected from 0.8.11; fixed in 1.30.4, 1.31.3\n- nginx-gateway (Bitnami): affected from 0.8.11; fixed in 1.30.4, 1.31.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56434/ (Markdown: https://insights.sbomify.com/CVE-2026-56434/index.md)","id":"CVE-2026-56434","markdown":"https://insights.sbomify.com/CVE-2026-56434/index.md","name":"CVE-2026-56434","record":{"aliases":["ALPINE-CVE-2026-56434","AZL-92496","BELL-CVE-2026-56434","BIT-nginx-2026-56434","BIT-nginx-gateway-2026-56434","CLSA-2026-1787916225","CLSA-2026-1788337827","CLSA-2026-1788338106","CLSA-2026-1792768371","CLSA-2026-1792768506","DEBIAN-CVE-2026-56434","ECHO-9338-7b65-6a75","GHSA-m73p-xg7q-m8f2","MINI-27xg-6v5c-fjmr","MINI-65cf-7gcf-r8p7","MINI-8m5w-w5x3-3rmf","MINI-fq8q-v527-852w","MINI-vm2g-fhc4-h36c","MINI-x392-627h-h8f5","ROOT-OS-ALPINE-315-CVE-2026-56434","ROOT-OS-ALPINE-320-CVE-2026-56434","ROOT-OS-DEBIAN-11-CVE-2026-56434","UBUNTU-CVE-2026-56434"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX web server","requires_auth":"none","summary":"An unauthenticated attacker with MITM capabilities can trigger a use-after-free in NGINX, causing worker restarts or limited memory modification.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_gateway_fabric","vendor":"f5"},{"product":"nginx_ingress_controller","vendor":"f5"},{"product":"nginx_plus","vendor":"f5"},{"product":"waf","vendor":"f5"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssi_module module. This vulnerability may exist when the Server-Side Includes (SSI), proxy_pass, and proxy_buffering off directives are configured. With this configuration, an unauthenticated attacker with man-in-the-middle (MITM) ability to control responses from an upstream server may be able to cause a use-after-free in the NGINX worker process. This issue may lead to limited modification of memory or a restart of the NGINX worker process.\n\nImpact:\nThis vulnerability may allow remote attackers to have limited control to modify memory contents or restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only.\n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX ngx_http_ssi_module vulnerability","id":"CVE-2026-56434","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"use_after_free","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Uncontrolled search path element issue exists in Pupsman versions prior to 3.9.0.","id":"CVE-2026-56437"},"packages":[{"ecosystem":"Bitnami","fixed":["1.30.4","1.31.3"],"introduced":["0.8.11","1.31.0"],"last_affected":[],"package":"nginx","purl":"pkg:bitnami/nginx","source":"BIT-nginx-2026-56434"},{"ecosystem":"Bitnami","fixed":["1.30.4","1.31.3"],"introduced":["0.8.11","1.31.0"],"last_affected":[],"package":"nginx-gateway","purl":"pkg:bitnami/nginx-gateway","source":"BIT-nginx-gateway-2026-56434"}],"prev":{"headline":"Hardcoded credentials in BSH ELP (Electronic Platform) Modules","id":"CVE-2026-56428"},"products":["NGINX Open Source","NGINX Plus"],"published":"2026-07-15","related":[{"cvss_score":9.2,"headline":"NGINX Map directive and Regex matching vulnerability","id":"CVE-2026-42533","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":9.2,"headline":"NGINX Open-Source ngx_http_v3_module vulnerability","id":"CVE-2026-42530","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.8,"headline":"NGINX ngx_http_slice_module vulnerability","id":"CVE-2026-60005","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.6,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-11311","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.6,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-50107","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.2,"headline":"NGINX vulnerability","id":"CVE-2026-1642","kev_date_added":null,"published":"2026-02-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["F5"]},"summary":"An unauthenticated attacker with MITM capabilities can trigger a use-after-free in NGINX, causing worker restarts or limited memory modification.","url":"https://insights.sbomify.com/CVE-2026-56434/"}