# CVE-2026-56443: Gitea: Token public-only scope bypassed on Limited-visibility owners (Repository + Package categories) — residual after CVE-2026-25714 / PR #37118

> Attackers can bypass token public-only scope restrictions to access limited-visibility repositories and packages in Gitea.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-7p4h-3gxq-x3h3, GO-2026-6045, MINI-62rp-9f5m-j6w5, MINI-fpcm-f4p6-fwgw

## What is CVE-2026-56443?

CVE-2026-56443 is a critical authentication bypass vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Token public-only scope bypassed on Limited-visibility owners (Repository + Package categories) — residual after CVE-2026-25714 / PR #37118

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-56443?

5 open source packages ship an affected version, including gitea.dev and code.gitea.io/gitea.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitea.dev` | Go | All versions | 1.27.0 |
| `gitea.dev` | Go | All versions | 1.27.0 |
| `gitea.dev` | Go | All versions | 1.27.0 |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |

## How do I fix CVE-2026-56443?

Upgrade gitea.dev to 1.27.0 or later.

## Is CVE-2026-56443 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56443 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56443 and fix it if it is affected.

What it is: CVE-2026-56443 is a critical authentication bypass vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56443 exists.

Affected packages and fixed versions:
- gitea.dev (Go): affected all versions; fixed in 1.27.0
- gitea.dev (Go): affected all versions; fixed in 1.27.0
- gitea.dev (Go): affected all versions; fixed in 1.27.0
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56443/ (Markdown: https://insights.sbomify.com/CVE-2026-56443/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56443
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56443
- OSV: https://osv.dev/vulnerability/CVE-2026-56443

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56443/
Summaries are generated and may contain mistakes; the official description above is the record.
