# CVE-2026-56449: Apache HTTP Server: mod_proxy_html: crash in dump_content

> An attacker can cause a denial of service in Apache HTTP Server by sending crafted HTTP response bodies to the mod_proxy_html module.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** ALPINE-CVE-2026-56449, AZL-106794, BELL-CVE-2026-56449, BIT-apache-2026-56449, DEBIAN-CVE-2026-56449, ECHO-f4b6-1ea9-1be2, GHSA-76ff-8r4r-vpm8, MINI-m4h7-2m9p-5chp, RHBA-2026:50158, ROOT-OS-DEBIAN-12-CVE-2026-56449, UBUNTU-CVE-2026-56449

## What is CVE-2026-56449?

CVE-2026-56449 is a high-severity memory corruption vulnerability in Apache Http Server, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Out-of-bounds Write vulnerability in Apache HTTP Server's mod_proxy_html with crafted HTTP response bodies.

This issue affects Apache HTTP Server version 2.4.68.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-56449?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.69 |
| `httpd` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `httpd-core` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `httpd-core-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `httpd-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `httpd-debugsource` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `httpd-devel` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `httpd-filesystem` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `httpd-manual` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `httpd-tools` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `httpd-tools-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `mod_ldap` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `mod_ldap-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `mod_lua` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `mod_lua-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `mod_proxy_html` | Red Hat:enterprise_linux:10.2 | All versions | 1:2.4.63-13.el10_2.5 |
| `mod_proxy_html-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 1:2.4.63-13.el10_2.5 |
| `mod_session` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `mod_session-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.5 |
| `mod_ssl` | Red Hat:enterprise_linux:10.2 | All versions | 1:2.4.63-13.el10_2.5 |
| `mod_ssl-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 1:2.4.63-13.el10_2.5 |

Products: Apache Http Server.

## How do I fix CVE-2026-56449?

Upgrade apache to 2.4.69 or later.

## Is CVE-2026-56449 being exploited?

There is no known exploitation of CVE-2026-56449 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56449 and fix it if it is affected.

What it is: CVE-2026-56449 is a high-severity memory corruption vulnerability in Apache Http Server, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56449 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.69

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56449/ (Markdown: https://insights.sbomify.com/CVE-2026-56449/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56449
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56449
- OSV: https://osv.dev/vulnerability/CVE-2026-56449

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56449/
Summaries are generated and may contain mistakes; the official description above is the record.
