{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56660 exists.","fix":"No fix has been published for CVE-2026-56660 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-56660 is a critical path traversal vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56660 and fix it if it is affected.\n\nWhat it is: CVE-2026-56660 is a critical path traversal vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56660 exists.\n\nAffected product: GetSimpleCMS-CE. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56660/ (Markdown: https://insights.sbomify.com/CVE-2026-56660/index.md)","id":"CVE-2026-56660","markdown":"https://insights.sbomify.com/CVE-2026-56660/index.md","name":"CVE-2026-56660","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"GetSimple CMS","requires_auth":"high_privilege","summary":"Attackers can achieve remote code execution via unsafe ZIP extraction and path traversal in the update handler, allowing file writes outside the web root.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"},{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"GetSimple CMS is a content management system (CMS), and GetSimple CMS CE is the community edition of that CMS. Prior to version 1.5, the update handler in UpdateCE.php downloads a ZIP archive and extracts its contents into the web root without validating file types or extraction paths. Because PHP files are written into a web-accessible directory, an attacker who can cause a malicious archive to be processed achieves remote code execution as the web-server user. Entry names are also used unsafely, allowing directory traversal (../) to write files outside the intended extraction directory. This issue has been patched in version 1.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"GetSimple CMS: CSRF, SSRF, and Unrestricted Zip Extraction","id":"CVE-2026-56660","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"GetSimple CMS: Server-Side Request Forgery in the UpdateCE update endpoint","id":"CVE-2026-56661"},"packages":[],"prev":{"headline":"Gitea SSH Key Parser Denial of Service","id":"CVE-2026-56657"},"products":["GetSimpleCMS-CE"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["GetSimpleCMS-CE"]},"summary":"Attackers can achieve remote code execution via unsafe ZIP extraction and path traversal in the update handler, allowing file writes outside the web root.","url":"https://insights.sbomify.com/CVE-2026-56660/"}