# CVE-2026-56660: GetSimple CMS: CSRF, SSRF, and Unrestricted Zip Extraction

> Attackers can achieve remote code execution via unsafe ZIP extraction and path traversal in the update handler, allowing file writes outside the web root.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026

## What is CVE-2026-56660?

CVE-2026-56660 is a critical path traversal vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GetSimple CMS is a content management system (CMS), and GetSimple CMS CE is the community edition of that CMS. Prior to version 1.5, the update handler in UpdateCE.php downloads a ZIP archive and extracts its contents into the web root without validating file types or extraction paths. Because PHP files are written into a web-accessible directory, an attacker who can cause a malicious archive to be processed achieves remote code execution as the web-server user. Entry names are also used unsafely, allowing directory traversal (../) to write files outside the intended extraction directory. This issue has been patched in version 1.5.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-434 (Unrestricted Upload of File with Dangerous Type), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-56660?


## How do I fix CVE-2026-56660?

No fix has been published for CVE-2026-56660 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56660 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56660 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56660 and fix it if it is affected.

What it is: CVE-2026-56660 is a critical path traversal vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56660 exists.

Affected product: GetSimpleCMS-CE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56660/ (Markdown: https://insights.sbomify.com/CVE-2026-56660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56660
- OSV: https://osv.dev/vulnerability/CVE-2026-56660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56660/
Summaries are generated and may contain mistakes; the official description above is the record.
