{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56661 exists.","fix":"No fix has been published for CVE-2026-56661 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-56661 is a high-severity server-side request forgery vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-56661 and fix it if it is affected.\n\nWhat it is: CVE-2026-56661 is a high-severity server-side request forgery vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56661 exists.\n\nAffected product: GetSimpleCMS-CE. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56661/ (Markdown: https://insights.sbomify.com/CVE-2026-56661/index.md)","id":"CVE-2026-56661","markdown":"https://insights.sbomify.com/CVE-2026-56661/index.md","name":"CVE-2026-56661","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GetSimple CMS","requires_auth":"high_privilege","summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in GetSimple CMS to read internal network resources and cloud metadata via the update endpoint.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"GetSimple CMS is a content management system (CMS), and GetSimple CMS CE is the community edition of that CMS. Prior to version 1.5, the update handler fetches a user-supplied URL with file_get_contents() after only format validation (FILTER_VALIDATE_URL) — there is no validation of the request destination. An attacker who can submit the form can make the server issue requests to arbitrary destinations, including internal-only services and cloud metadata endpoints (169.254.169.254). The fetched response body is written to a web-accessible file (/Tmpfile.zip) and is not deleted when the content is not a valid ZIP, turning this into a full-read SSRF: the attacker can retrieve the response of the internal request directly. This issue has been patched in version 1.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"GetSimple CMS: Server-Side Request Forgery in the UpdateCE update endpoint","id":"CVE-2026-56661","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"GetSimple CMS: Missing CSRF protection in UpdateCE allows forging a privileged server-side update request","id":"CVE-2026-56662"},"packages":[],"prev":{"headline":"GetSimple CMS: CSRF, SSRF, and Unrestricted Zip Extraction","id":"CVE-2026-56660"},"products":["GetSimpleCMS-CE"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["GetSimpleCMS-CE"]},"summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in GetSimple CMS to read internal network resources and cloud metadata via the update endpoint.","url":"https://insights.sbomify.com/CVE-2026-56661/"}