# CVE-2026-56661: GetSimple CMS: Server-Side Request Forgery in the UpdateCE update endpoint

> An attacker can exploit a Server-Side Request Forgery vulnerability in GetSimple CMS to read internal network resources and cloud metadata via the update endpoint.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026

## What is CVE-2026-56661?

CVE-2026-56661 is a high-severity server-side request forgery vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

GetSimple CMS is a content management system (CMS), and GetSimple CMS CE is the community edition of that CMS. Prior to version 1.5, the update handler fetches a user-supplied URL with file_get_contents() after only format validation (FILTER_VALIDATE_URL) — there is no validation of the request destination. An attacker who can submit the form can make the server issue requests to arbitrary destinations, including internal-only services and cloud metadata endpoints (169.254.169.254). The fetched response body is written to a web-accessible file (/Tmpfile.zip) and is not deleted when the content is not a valid ZIP, turning this into a full-read SSRF: the attacker can retrieve the response of the internal request directly. This issue has been patched in version 1.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-56661?


## How do I fix CVE-2026-56661?

No fix has been published for CVE-2026-56661 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56661 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56661 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56661 and fix it if it is affected.

What it is: CVE-2026-56661 is a high-severity server-side request forgery vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56661 exists.

Affected product: GetSimpleCMS-CE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56661/ (Markdown: https://insights.sbomify.com/CVE-2026-56661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56661
- OSV: https://osv.dev/vulnerability/CVE-2026-56661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56661/
Summaries are generated and may contain mistakes; the official description above is the record.
