# CVE-2026-56662: GetSimple CMS: Missing CSRF protection in UpdateCE allows forging a privileged server-side update request

> A missing CSRF token in GetSimple CMS allows attackers to force administrators to execute remote code via forged update requests.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Oct 2026
- **Updated:** 6 Oct 2026

## What is CVE-2026-56662?

CVE-2026-56662 is a critical vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

GetSimple CMS is a content management system (CMS), and GetSimple CMS CE is the community edition of that CMS. Prior to version 1.5, the UpdateCE update form contained no anti-CSRF token, and the POST handler performed no token or request-origin verification. A remote attacker can host a page that auto-submits a forged POST to the update endpoint; when an authenticated administrator visits it, the server performs an attacker-directed download-and-deploy operation in the administrator's session — with no further interaction. Because the deployed content is executed (see the related ZIP-extraction advisory), this yields remote code execution. The url field is additionally written into the form unescaped, providing a secondary HTML-injection sink via a malicious upgrade.json. This issue has been patched in version 1.5.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-56662?


## How do I fix CVE-2026-56662?

No fix has been published for CVE-2026-56662 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56662 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56662 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56662 and fix it if it is affected.

What it is: CVE-2026-56662 is a critical vulnerability in GetSimpleCMS-CE, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56662 exists.

Affected product: GetSimpleCMS-CE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56662/ (Markdown: https://insights.sbomify.com/CVE-2026-56662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56662
- OSV: https://osv.dev/vulnerability/CVE-2026-56662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56662/
Summaries are generated and may contain mistakes; the official description above is the record.
