# CVE-2026-56663: AutoGPT: SSRF-to-RCE Chain in `SendWebRequestBlock` via IP validation bypass and internal `pg-meta` access

> Authenticated attackers can bypass SSRF protections to access internal services, potentially leading to remote code execution in AutoGPT.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-8qc5-rhmg-r6r6

## What is CVE-2026-56663?

CVE-2026-56663 is a high-severity server-side request forgery vulnerability in Significant-Gravitas AutoGPT, published on 26 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.52, an authenticated user can bypass the SSRF / private-IP protections in SendWebRequestBlock and reach internal network services. _is_ip_blocked() in backend/backend/util/request.py does not normalize IPv4-mapped IPv6 addresses before checking resolved IPs against the blocked IPv4 ranges, and does not block special-use ranges such as 100.64.0.0/10 (CGNAT, RFC 6598). A hostname that resolves to an IPv4-mapped IPv6 address therefore passes validation and the request reaches the embedded internal IPv4 endpoint. This affects all AutoGPT Platform deployments. This vulnerability is fixed in 0.6.52.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-56663?


## How do I fix CVE-2026-56663?

No fix has been published for CVE-2026-56663 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56663 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56663 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56663 and fix it if it is affected.

What it is: CVE-2026-56663 is a high-severity server-side request forgery vulnerability in Significant-Gravitas AutoGPT, published on 26 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56663 exists.

Affected product: Significant-Gravitas AutoGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56663/ (Markdown: https://insights.sbomify.com/CVE-2026-56663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56663
- OSV: https://osv.dev/vulnerability/CVE-2026-56663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56663/
Summaries are generated and may contain mistakes; the official description above is the record.
