# CVE-2026-56668: ZITADEL: Unauthorized Token Privilege Escalation in OAuth2 Token Exchange

> Attackers can exchange low-privilege tokens for elevated permissions in other applications due to missing validation in ZITADEL's OAuth2 token exchange endpoint.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-vrh8-c9cm-wh8v, GO-2026-6474

## What is CVE-2026-56668?

CVE-2026-56668 is a high-severity vulnerability in zitadel, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ZITADEL is an open source identity management platform. Prior to 4.15.3, ZITADEL's OAuth2 Token Exchange endpoint for urn:ietf:params:oauth:grant-type:token-exchange does not verify that the subject token belongs to the requesting client or that requested scopes remain within the original token's scopes, allowing a low-privilege token to be exchanged for elevated permissions at another application. This issue is fixed in version 4.15.3.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-56668?

3 open source packages ship an affected version, including github.com/zitadel/zitadel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zitadel/zitadel` | Go | All versions | None |
| `github.com/zitadel/zitadel` | Go | All versions | 4.15.3 |
| `github.com/zitadel/zitadel` | Go | All versions | 4.15.3 |

## How do I fix CVE-2026-56668?

Upgrade github.com/zitadel/zitadel to 4.15.3 or later.

## Is CVE-2026-56668 being exploited?

There is no known exploitation of CVE-2026-56668 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56668 and fix it if it is affected.

What it is: CVE-2026-56668 is a high-severity vulnerability in zitadel, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56668 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/zitadel/zitadel (Go): affected all versions; no fix listed
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 4.15.3
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 4.15.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56668/ (Markdown: https://insights.sbomify.com/CVE-2026-56668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56668
- OSV: https://osv.dev/vulnerability/CVE-2026-56668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56668/
Summaries are generated and may contain mistakes; the official description above is the record.
