# CVE-2026-56669: Elysia: Inefficient Algorithmic Complexity and Interpretation Conflict

> Attackers can cause CPU exhaustion in Elysia applications by sending multipart requests with many unique keys, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-9643-4qgh-g8mx

## What is CVE-2026-56669?

CVE-2026-56669 is a high-severity denial of service vulnerability in elysiajs elysia, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation, and client-server communication. Prior to 1.4.29, Elysia uses getAll in form data normalization for multipart/form-data endpoints, causing the amount of work to grow quadratically with the number of unique key-value pairs and allowing CPU exhaustion. This issue is fixed in version 1.4.29.

Weakness: CWE-436 (Interpretation Conflict), CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-56669?

2 open source packages ship an affected version, including elysia.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elysia` | npm | All versions | 1.4.29 |
| `elysia` | npm | All versions | 1.4.29 |

## How do I fix CVE-2026-56669?

Upgrade elysia to 1.4.29 or later.

## Is CVE-2026-56669 being exploited?

There is no known exploitation of CVE-2026-56669 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56669 and fix it if it is affected.

What it is: CVE-2026-56669 is a high-severity denial of service vulnerability in elysiajs elysia, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56669 in the wild and no public exploit code.

Affected packages and fixed versions:
- elysia (npm): affected all versions; fixed in 1.4.29
- elysia (npm): affected all versions; fixed in 1.4.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56669/ (Markdown: https://insights.sbomify.com/CVE-2026-56669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56669
- OSV: https://osv.dev/vulnerability/CVE-2026-56669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56669/
Summaries are generated and may contain mistakes; the official description above is the record.
