CVE-2026-56670 ComfyUI: Stored XSS via SVG file upload on the /view endpoint
Attackers can execute arbitrary scripts in the ComfyUI origin by uploading malicious SVG files served inline by the view endpoint.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-56670?
CVE-2026-56670 is a high-severity cross-site scripting vulnerability in Comfy-Org ComfyUI, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
ComfyUI is a modular diffusion model GUI, api and backend with a graph/nodes interface. Prior to 0.28.0, the /view endpoint served uploaded SVG files inline because image/svg+xml and related XML content types were absent from the dangerous-content-type handling, allowing stored cross-site scripting in the ComfyUI origin. This issue is fixed in version 0.28.0.
Weakness: CWE-79
Which versions are affected by CVE-2026-56670?
Linux distribution packages (1)
comfyui openSUSE:Tumbleweed | All versions | 0.33.3-1.1 |
How do I fix CVE-2026-56670?
Upgrade to a fixed version.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-56670 being exploited?
There is no known exploitation of CVE-2026-56670 in the wild and no public exploit code.
Sources
Also known as GHSA-rj8c-c4p8-3c5h, openSUSE-SU-2026:11562-1.