# CVE-2026-56673: ComfyUI: Path traversal in LoadImage via the /prompt API allows arbitrary file existence probing and image exfiltration

> Unauthenticated attackers can probe arbitrary host paths and exfiltrate image files via crafted workflow inputs in ComfyUI.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-rvxv-29p8-pxgq

## What is CVE-2026-56673?

CVE-2026-56673 is a high-severity path traversal vulnerability in Comfy-Org ComfyUI, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ComfyUI is a modular diffusion model GUI, API, and backend with a graph-and-node interface. Prior to 0.28.0, folder_paths.get_annotated_filepath and exists_annotated_filepath join workflow-controlled annotated filenames to a base directory without a containment check, allowing an unauthenticated crafted POST /prompt workflow using LoadImage or sibling nodes to probe arbitrary host paths and exfiltrate image-format files through /view. LoadImage defines a VALIDATE_INPUTS method, which causes the execution engine to skip COMBO (input-directory) validation. Affected nodes include LoadImage, LoadImageMask, LoadImageOutput, LoadAudio, LoadLatent, LoadVideo, and Load3D. This issue is fixed in version 0.28.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-56673?


## How do I fix CVE-2026-56673?

No fix has been published for CVE-2026-56673 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56673 being exploited?

There is no known exploitation of CVE-2026-56673 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56673 and fix it if it is affected.

What it is: CVE-2026-56673 is a high-severity path traversal vulnerability in Comfy-Org ComfyUI, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56673 in the wild and no public exploit code.

Affected product: Comfy-Org ComfyUI. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56673/ (Markdown: https://insights.sbomify.com/CVE-2026-56673/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56673
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56673
- OSV: https://osv.dev/vulnerability/CVE-2026-56673

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56673/
Summaries are generated and may contain mistakes; the official description above is the record.
