{"answers":{"affected":"2 open source packages ship an affected version, including 9router.","exploited":"There is no known exploitation of CVE-2026-56675 in the wild and no public exploit code.","fix":"Upgrade 9router to 0.5.2 or later.","what":"CVE-2026-56675 is a high-severity authentication bypass vulnerability in decolua 9router, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56675 and fix it if it is affected.\n\nWhat it is: CVE-2026-56675 is a high-severity authentication bypass vulnerability in decolua 9router, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-56675 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- 9router (npm): affected all versions; fixed in 0.5.2\n- 9router (npm): affected all versions; fixed in 0.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56675/ (Markdown: https://insights.sbomify.com/CVE-2026-56675/index.md)","id":"CVE-2026-56675","markdown":"https://insights.sbomify.com/CVE-2026-56675/index.md","name":"CVE-2026-56675","record":{"aliases":["GHSA-x5c9-v98j-722r"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"AI router proxy","requires_auth":"none","summary":"Remote attackers can bypass authentication and access APIs by exploiting reverse proxy misclassification of loopback traffic in 9router.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-441","name":"Unintended Proxy or Intermediary"},{"id":"CWE-290","name":"Authentication Bypass by Spoofing"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"9Router is an AI router \u0026 token saver. Prior to 0.5.2, 9router treats loopback requests as trusted and allows /v1/* access without an API key, so a same-host reverse proxy that forwards public traffic to the backend through 127.0.0.1 causes src/dashboardGuard.js to misclassify external requests as local. A remote unauthenticated attacker can access /v1 APIs such as /v1/models and may abuse configured upstream provider credentials through /v1 proxy endpoints depending on enabled providers. This issue is fixed in version 0.5.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"9router: Reverse proxy locality collapse allows unauthenticated access to 9router /v1 APIs","id":"CVE-2026-56675","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"9router: Image prefetch DNS rebinding allows SSRF to internal services","id":"CVE-2026-56676"},"packages":[{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"9router","purl":null,"source":"GHSA-x5c9-v98j-722r"},{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"9router","purl":"pkg:npm/9router","source":"GHSA-x5c9-v98j-722r"}],"prev":{"headline":"ComfyUI: Path traversal in LoadImage via the /prompt API allows arbitrary file existence probing and image exfiltration","id":"CVE-2026-56673"},"products":["9router"],"published":"2026-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-10","vendors":["decolua"]},"summary":"Remote attackers can bypass authentication and access APIs by exploiting reverse proxy misclassification of loopback traffic in 9router.","url":"https://insights.sbomify.com/CVE-2026-56675/"}