# CVE-2026-56676: 9router: Image prefetch DNS rebinding allows SSRF to internal services

> An authenticated attacker can exploit DNS rebinding in image prefetching to access internal services via the AI router proxy.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-cmhj-wh2f-9cgx

## What is CVE-2026-56676?

CVE-2026-56676 is a high-severity server-side request forgery vulnerability in decolua 9router, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

9Router is an AI router & token saver. Prior to 0.5.2, 9router validates image URLs by resolving the host before fetching, but open-sse/translator/concerns/image.js performs the later server-side image fetch with a separate DNS resolution. An authenticated attacker with access to the LLM proxy can use a vision-capable model and an attacker-controlled DNS name that first resolves to a public IP and then rebinds to an internal address, allowing server-side requests to internal-only HTTP services. This issue is fixed in version 0.5.2.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-56676?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | All versions | 0.5.2 |
| `9router` | npm | All versions | 0.5.2 |

## How do I fix CVE-2026-56676?

Upgrade 9router to 0.5.2 or later.

## Is CVE-2026-56676 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56676 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56676 and fix it if it is affected.

What it is: CVE-2026-56676 is a high-severity server-side request forgery vulnerability in decolua 9router, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56676 exists.

Affected packages and fixed versions:
- 9router (npm): affected all versions; fixed in 0.5.2
- 9router (npm): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56676/ (Markdown: https://insights.sbomify.com/CVE-2026-56676/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56676
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56676
- OSV: https://osv.dev/vulnerability/CVE-2026-56676

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56676/
Summaries are generated and may contain mistakes; the official description above is the record.
