{"answers":{"affected":"2 open source packages ship an affected version, including 9router.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56678 exists.","fix":"Upgrade 9router to 0.5.6 or later.","what":"CVE-2026-56678 is a medium-severity server-side request forgery vulnerability in decolua 9router, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56678 and fix it if it is affected.\n\nWhat it is: CVE-2026-56678 is a medium-severity server-side request forgery vulnerability in decolua 9router, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56678 exists.\n\nAffected packages and fixed versions:\n- 9router (npm): affected all versions; fixed in 0.5.6\n- 9router (npm): affected all versions; fixed in 0.5.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56678/ (Markdown: https://insights.sbomify.com/CVE-2026-56678/index.md)","id":"CVE-2026-56678","markdown":"https://insights.sbomify.com/CVE-2026-56678/index.md","name":"CVE-2026-56678","record":{"aliases":["GHSA-6mwv-4mrm-5p3m"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AI router service","requires_auth":"low_privilege","summary":"Authenticated attackers can exploit region injection to trigger SSRF and leak API keys via forwarded Authorization headers in 9Router.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"9Router is an AI router \u0026 token saver. Prior to 0.5.6, the Kiro API-key validation endpoint POST /api/oauth/kiro/api-key builds an upstream URL using a user-controlled region value, allowing an authenticated attacker to supply a crafted region such as kiro-canary.local:8443# and cause 9Router to send the Kiro validation request to an attacker-controlled host while forwarding the submitted Kiro API key as an Authorization header. This issue is fixed in version 0.5.6.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"9Router: Kiro region injection allows authenticated SSRF with Authorization header forwarding","id":"CVE-2026-56678","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"9Router: Mass assignment in PATCH /api/settings allows authenticated authorization downgrade","id":"CVE-2026-56679"},"packages":[{"ecosystem":"npm","fixed":["0.5.6"],"introduced":["0"],"last_affected":[],"package":"9router","purl":null,"source":"GHSA-6mwv-4mrm-5p3m"},{"ecosystem":"npm","fixed":["0.5.6"],"introduced":["0"],"last_affected":[],"package":"9router","purl":"pkg:npm/9router","source":"GHSA-6mwv-4mrm-5p3m"}],"prev":{"headline":"9Router: Authenticated Server-Side Request Forgery (SSRF) via OIDC Provider Test Endpoint","id":"CVE-2026-56677"},"products":["9router"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-16","vendors":["decolua"]},"summary":"Authenticated attackers can exploit region injection to trigger SSRF and leak API keys via forwarded Authorization headers in 9Router.","url":"https://insights.sbomify.com/CVE-2026-56678/"}