# CVE-2026-56678: 9Router: Kiro region injection allows authenticated SSRF with Authorization header forwarding

> Authenticated attackers can exploit region injection to trigger SSRF and leak API keys via forwarded Authorization headers in 9Router.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** GHSA-6mwv-4mrm-5p3m

## What is CVE-2026-56678?

CVE-2026-56678 is a medium-severity server-side request forgery vulnerability in decolua 9router, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

9Router is an AI router & token saver. Prior to 0.5.6, the Kiro API-key validation endpoint POST /api/oauth/kiro/api-key builds an upstream URL using a user-controlled region value, allowing an authenticated attacker to supply a crafted region such as kiro-canary.local:8443# and cause 9Router to send the Kiro validation request to an attacker-controlled host while forwarding the submitted Kiro API key as an Authorization header. This issue is fixed in version 0.5.6.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-56678?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | All versions | 0.5.6 |
| `9router` | npm | All versions | 0.5.6 |

## How do I fix CVE-2026-56678?

Upgrade 9router to 0.5.6 or later.

## Is CVE-2026-56678 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56678 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56678 and fix it if it is affected.

What it is: CVE-2026-56678 is a medium-severity server-side request forgery vulnerability in decolua 9router, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56678 exists.

Affected packages and fixed versions:
- 9router (npm): affected all versions; fixed in 0.5.6
- 9router (npm): affected all versions; fixed in 0.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56678/ (Markdown: https://insights.sbomify.com/CVE-2026-56678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56678
- OSV: https://osv.dev/vulnerability/CVE-2026-56678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56678/
Summaries are generated and may contain mistakes; the official description above is the record.
