{"answers":{"affected":"2 open source packages ship an affected version, including 9router.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56679 exists.","fix":"Upgrade 9router to 0.5.4 or later.","what":"CVE-2026-56679 is a high-severity missing authorization vulnerability in decolua 9router, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56679 and fix it if it is affected.\n\nWhat it is: CVE-2026-56679 is a high-severity missing authorization vulnerability in decolua 9router, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56679 exists.\n\nAffected packages and fixed versions:\n- 9router (npm): affected all versions; fixed in 0.5.4\n- 9router (npm): affected all versions; fixed in 0.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56679/ (Markdown: https://insights.sbomify.com/CVE-2026-56679/index.md)","id":"CVE-2026-56679","markdown":"https://insights.sbomify.com/CVE-2026-56679/index.md","name":"CVE-2026-56679","record":{"aliases":["GHSA-vmjq-hvgq-2wv4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"AI router application","requires_auth":"low_privilege","summary":"Authenticated users can downgrade security settings via mass assignment, exposing protected API routes to unauthenticated access.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-915","name":"Improperly Controlled Modification of Dynamically-Determined Object Attributes"}],"description":"9Router is an AI router \u0026 token saver. Prior to 0.5.4, the PATCH /api/settings endpoint writes the entire request body to persistent settings without a field whitelist, allowing an authenticated user to set security-critical fields such as requireLogin and disable authentication for the whole application, exposing protected routes such as /api/keys and /api/providers to unauthenticated access. This issue is reported as fixed in version 0.5.4.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"9Router: Mass assignment in PATCH /api/settings allows authenticated authorization downgrade","id":"CVE-2026-56679","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"9Router: Authentication Bypass in Public LLM API via Spoofable X-9r-Real-Ip Header","id":"CVE-2026-56681"},"packages":[{"ecosystem":"npm","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"9router","purl":null,"source":"GHSA-vmjq-hvgq-2wv4"},{"ecosystem":"npm","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"9router","purl":"pkg:npm/9router","source":"GHSA-vmjq-hvgq-2wv4"}],"prev":{"headline":"9Router: Kiro region injection allows authenticated SSRF with Authorization header forwarding","id":"CVE-2026-56678"},"products":["9router"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-16","vendors":["decolua"]},"summary":"Authenticated users can downgrade security settings via mass assignment, exposing protected API routes to unauthenticated access.","url":"https://insights.sbomify.com/CVE-2026-56679/"}