CVE-2026-56681 9Router: Authentication Bypass in Public LLM API via Spoofable X-9r-Real-Ip Header
Remote attackers can bypass API key validation by spoofing the X-9r-Real-Ip header to access LLM providers and consume credits.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-56681?
CVE-2026-56681 is a high-severity authentication bypass vulnerability in decolua 9router, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
9Router is an AI router & token saver. Prior to 0.5.6, 9Router deployments that allow requests to reach Next.js without the sanitizing custom-server.js wrapper trust the client-supplied X-9r-Real-Ip header in src/dashboardGuard.js when isLocalRequest decides whether canAccessPublicLlmApi may skip API-key validation for /api/v1/* routes. A remote unauthenticated attacker can set X-9r-Real-Ip to 127.0.0.1 and be classified as a local client, including on the verified GET /api/v1/models route. This permits unauthorized use of the instance owner's configured LLM providers, consumption of paid credits, and enumeration of configured providers and models. This issue is fixed in version 0.5.6.
Weakness: CWE-807
Which versions are affected by CVE-2026-56681?
2 open source packages ship an affected version, including 9router.
| Package | Affected | Fixed in |
|---|---|---|
9router npm | All versions | 0.5.8 |
9router npm | All versions | 0.5.8 |
How do I fix CVE-2026-56681?
Upgrade 9router to 0.5.8 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-56681 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56681 exists.
Public exploit code: 1 Nuclei template.
Sources
Also known as GHSA-5mj8-gf6m-fhw8.