# CVE-2026-56681: 9Router: Authentication Bypass in Public LLM API via Spoofable X-9r-Real-Ip Header

> Remote attackers can bypass API key validation by spoofing the X-9r-Real-Ip header to access LLM providers and consume credits.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-5mj8-gf6m-fhw8

## What is CVE-2026-56681?

CVE-2026-56681 is a high-severity authentication bypass vulnerability in decolua 9router, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

9Router is an AI router & token saver. Prior to 0.5.6, 9Router deployments that allow requests to reach Next.js without the sanitizing custom-server.js wrapper trust the client-supplied X-9r-Real-Ip header in src/dashboardGuard.js when isLocalRequest decides whether canAccessPublicLlmApi may skip API-key validation for /api/v1/* routes. A remote unauthenticated attacker can set X-9r-Real-Ip to 127.0.0.1 and be classified as a local client, including on the verified GET /api/v1/models route. This permits unauthorized use of the instance owner's configured LLM providers, consumption of paid credits, and enumeration of configured providers and models. This issue is fixed in version 0.5.6.

Weakness: CWE-807 (Reliance on Untrusted Inputs in a Security Decision)

## Which versions are affected by CVE-2026-56681?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | All versions | 0.5.8 |
| `9router` | npm | All versions | 0.5.8 |

## How do I fix CVE-2026-56681?

Upgrade 9router to 0.5.8 or later.

## Is CVE-2026-56681 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56681 exists.

Public exploit code:

- 9router <=0.5.4 - Authentication Bypass (nuclei): http/cves/2026/CVE-2026-56681.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56681 and fix it if it is affected.

What it is: CVE-2026-56681 is a high-severity authentication bypass vulnerability in decolua 9router, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56681 exists.

Affected packages and fixed versions:
- 9router (npm): affected all versions; fixed in 0.5.8
- 9router (npm): affected all versions; fixed in 0.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56681/ (Markdown: https://insights.sbomify.com/CVE-2026-56681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56681
- OSV: https://osv.dev/vulnerability/CVE-2026-56681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56681/
Summaries are generated and may contain mistakes; the official description above is the record.
