# CVE-2026-56684: Valkey: TLS pending-data processing use-after-free may allow remote code execution

> An authenticated attacker can trigger a use-after-free in Valkey's TLS processing, potentially leading to remote code execution or server crashes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** AZL-96888, BELL-CVE-2026-56684, BIT-valkey-2026-56684, DEBIAN-CVE-2026-56684, GHSA-53mc-f3m3-99vh, UBUNTU-CVE-2026-56684

## What is CVE-2026-56684?

CVE-2026-56684 is a high-severity use after free vulnerability in valkey-io valkey, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Valkey is a distributed key-value database. Prior to 7.2.14, 8.0.10, 8.1.9, 9.0.5, and 9.1.1, Valkey's tlsProcessPendingData function iterates pending_list while an authenticated client can trigger CLIENT KILL, causing connTLSClose to delete the iterator's cached next node and producing a use-after-free that can crash the server or potentially allow remote code execution when TLS is enabled. This issue is fixed in versions 7.2.14, 8.0.10, 8.1.9, 9.0.5, and 9.1.1.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-56684?

1 open source package ship an affected version, including valkey.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `valkey` | Bitnami | All versions | 7.2.14, 8.0.10, 8.1.9, 9.0.5, 9.1.1 |

## How do I fix CVE-2026-56684?

Upgrade valkey to a fixed version for your release line: 7.2.14, 8.0.10, 8.1.9 or 9.0.5.

## Is CVE-2026-56684 being exploited?

There is no known exploitation of CVE-2026-56684 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56684 and fix it if it is affected.

What it is: CVE-2026-56684 is a high-severity use after free vulnerability in valkey-io valkey, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56684 in the wild and no public exploit code.

Affected packages and fixed versions:
- valkey (Bitnami): affected all versions; fixed in 7.2.14, 8.0.10, 8.1.9, 9.0.5, 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56684/ (Markdown: https://insights.sbomify.com/CVE-2026-56684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56684
- OSV: https://osv.dev/vulnerability/CVE-2026-56684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56684/
Summaries are generated and may contain mistakes; the official description above is the record.
