# CVE-2026-56700: Grav - Multiple Remote Code Execution Vulnerabilities via Unsafe Unserialize and Command Injection

> Attackers can achieve remote code execution in Grav CMS via unsafe deserialization and command injection vulnerabilities.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-58cg-x8gx-6hg3, GHSA-vj3m-2g9h-vm4p

## What is CVE-2026-56700?

CVE-2026-56700 is a critical unsafe deserialization vulnerability in Grav, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav CMS before 2.0.0-beta.2 contains multiple code-execution vulnerabilities. Three unsafe unserialize() calls - in Scheduler\JobQueue, Framework\Cache\Adapter\FileCache, and Session - deserialize untrusted data without restricting allowed classes, enabling PHP object injection and, via a gadget chain, arbitrary code execution where an attacker controls the serialized input. Additionally, InstallCommand's git clone operation passes the branch, url, and path parameters into a shell command without escaping, allowing OS command injection via plugin/theme installation (which requires admin access). A Twig security blocklist bypass (server-side template injection) is also present. The issues are fixed in 2.0.0-beta.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-56700?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |

## How do I fix CVE-2026-56700?

Upgrade getgrav/grav to 2.0.0-beta.2 or later.

## Is CVE-2026-56700 being exploited?

There is no known exploitation of CVE-2026-56700 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56700 and fix it if it is affected.

What it is: CVE-2026-56700 is a critical unsafe deserialization vulnerability in Grav, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56700 in the wild and no public exploit code.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56700/ (Markdown: https://insights.sbomify.com/CVE-2026-56700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56700
- OSV: https://osv.dev/vulnerability/CVE-2026-56700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56700/
Summaries are generated and may contain mistakes; the official description above is the record.
